OpenRoads Designer CONNECT Edition SDK Help

CircularArc Methods

Methods

Accept Accepts this element (Overrides LinearElement.Accept(LinearElementVisitor))
CloneInternal Creates a copy of this instance (Overrides LinearElement.CloneInternal())
Create1(DPoint3d, Double, Double, Double)  
Create1(DPoint3d, Double, Double, Double, Double)  
Create10  
Create11  
Create12  
Create13  
Create14  
Create15  
Create16  
Create2  
Create3  
Create4  
Create5(DPoint3d, DPoint3d, Double, Hand)  
Create5(DPoint3d, DPoint3d, Double, Hand, Double)  
Create6  
Create7(DPoint3d, DPoint3d, DPoint3d, Hand)  
Create7(DPoint3d, DPoint3d, DPoint3d, Hand, Double)  
Create8  
Create9  
CreateByCenterRadiusEndDirectionSweepAngleRotationDirection Constructs a circular arc element
CreateByCenterRadiusStartDirectionArcLength Constructs a circular arc element
CreateByCenterRadiusStartDirectionEndDirectionRotationDirection Constructs a circular arc element
CreateByCenterRadiusStartDirectionSweepAngle(DPoint3d, Double, Double, Double) Constructs a circular arc element
CreateByCenterRadiusStartDirectionSweepAngle(DPoint3d, Double, Double, Double, Double) Constructs a circular arc element
CreateByCenterRadiusStartDirectionSweepAngleRotationDirection Constructs a circular arc element
CreateByCenterStartPointEndPointRotationDirection(DPoint3d, DPoint3d, DPoint3d, Hand) Constructs a circular arc element
CreateByCenterStartPointEndPointRotationDirection(DPoint3d, DPoint3d, DPoint3d, Hand, Double)  
CreateByEndPointRadiusEndDirectionSweepAngleRotationDirection Constructs a circular arc element
CreateByStartPointEndPointEndDirectionRotationDirection Constructs a circular arc element
CreateByStartPointEndPointEndTangentDirection Constructs a circular arc element
CreateByStartPointEndPointRadiusRotationDirection Constructs a circular arc element
CreateByStartPointEndPointRadiusSweepAngle Constructs a circular arc element
CreateByStartPointEndPointStartDirectionRotationDirection(DPoint3d, DPoint3d, Double, Hand) Constructs a circular arc element
CreateByStartPointEndPointStartDirectionRotationDirection(DPoint3d, DPoint3d, Double, Hand, Double) Constructs a circular arc element
CreateByStartPointEndPointStartTangentDirection Constructs a circular arc element
CreateByStartPointEndPointThruPoint Constructs a circular arc element
CreateByStartPointPIPointEndPoint Constructs a circular arc element
CreateByStartPointRadiusStartDirectionSweepAngleRotationDirection Constructs a circular arc element
CreateTangentToCircleThruPointRadius Creates Tangent Line when given Circle, Thrupoint, and Radius
CreateTangentToCircleTwoThruPoints Creates Tangent Line when given Spiral, Thrupoint, and Radius
CreateTangentToLineAndCircleRadius Creates Tangent Line when given Spiral, Thrupoint, and Radius
CreateTangentToLineAndCircleThruPoint Creates Tangent Line when given Spiral, Thrupoint, and Radius
CreateTangentToLineThruPoint Creates Tangent Line when given Line and Thrupoint
CreateTangentToLineThruPointRadius Creates Tangent Line when given Line, Thrupoint, and Radius
CreateTangentToLineTwoThruPoints Creates Tangent Line when given Spiral, Thrupoint, and Radius
CreateTangentToSpiralThruPointRadius Creates Tangent Line when given Spiral, Thrupoint, and Radius
CreateTangentToSpiralTwoThruPoints Creates Tangent Line when given Spiral, Thrupoint, and Radius
CreateTangentToTwoCirclesRadius Creates Tangent Line when given Spiral, Thrupoint, and Radius
CreateTangentToTwoCirclesThruPoint Creates Tangent Line when given Spiral, Thrupoint, and Radius
CreateTangentToTwoElementsRadius Creates Tangent Line when given two elements and a thrupoint
CreateTangentToTwoElementsThruPoint Creates Tangent Line when given two elements and a thrupoint
CreateTangentToTwoLinesRadius Creates Tangent Line when given Spiral, Thrupoint, and Radius
CreateTangentToTwoLinesThruPoint Creates Tangent Line when given Spiral, Thrupoint, and Radius
GetDegreeOfCurvature Gets degree of curvature
GetLinearPointCollectionBySelection Ported from Bentley.CifNET.GeometryModel (src.cs) (Overrides LinearElement.GetLinearPointCollectionBySelection(PointSelectionOption, Double, Double, Double, Double))
PIPoint Gets the PI point of circular arc
ReplaceClosedArcWithComplex Ported from Bentley.CifNET.GeometryModel (src.cs)
Reverse Reverses the circular arc

See Also